Good day to all. The question may be somewhat stupid, but for me it’s not so trivial.

I tried to make my own compilation of Eclipse 3.0 (with some added features). On my system it worked perfectly, but when I tried to distribute it, client would crash with “Unrecoverable DX8 error” once we are on the map. It might be because the person who has this crash use Windows 8. Tried deleting maps from the client - the same error. Other person (also having the Win 8) tried the non-modified Eclipse 3.0 - no error. What can be wrong?

upd: he tried to run as administrator - got the “Subscript out of range” error on start (before login). Tested on my system - nothing similar.