Hosting A Server WITHOUT Portforwarding

Yes, I said it, host a server without Portforwarding, if you have a router. If you don’t, you don’t even need to portforward.

Step 1: Download the Vuze Installer.

Step 2: Open up Vuze.

Step 3: Open the tools tab.

Step 4: Open Options.

Step 5: On the options menu click Connection.

Step 6: Set the port to 7001, the defualt Eclispe Origins Port. (Or your custom port.)

Step 7: Apply Vuze Setting.

Step 8: Go back to the Tool>Options>Connection, and make sure your port is the port you set it to be, if not, set it again and apply.

Step 9: Run the server.

Step 10: Have your friends run the game and play!

EDIT: For uTorrent, go to preferences, connection, and change the port.

ALWAYS RUN THE SERVER FIRST, and then uTorrent/Vuze

I find uTorrent is better for port-forwarding, and vuze is better for… well… torrents.

Good luck!

That’s just abusing the UPnP function of Vuze. Might as well just use a dedicated UPnP program.

vuze installer= bittorrent app? 😮

its answome host a game without port fowarding

@DishWasher:

vuze installer= bittorrent app? 😮

its answome host a game without port fowarding

It is forwarding your ports. It’s just doing it for you.

oh,thanks both ^-^

i would only use this as a last resort.  vuse is a revamped azurus, and as such is full of icky crap you dont want.  i wouldnt even use it for torrents imho.

Might as well use µTorrent. Although, you shouldn’t rely on UPnP being enabled everywhere, since it is considered a security hole. But it should work where it is enabled.

Regards,
  Stephan.

Run-time Error ‘6’:

Overflow

Umm… help? it’s defiantly not overflow

That has absolutely nothing to do with this tutorial.

I did everything here, twice, maybe three times. I’m merely asking what did I do wrong? or Does it work Anymore? or I could just be reporting a error.

@S.J.R.:

Might as well use µTorrent. Although, you shouldn’t rely on UPnP being enabled everywhere, since it is considered a security hole. But it should work where it is enabled.

Regards,
  Stephan.

I think i tried utorrent to fix it for someone once and you just get address in use errors.

@UltimateAngelsCorp:

I did everything here, twice, maybe three times. I’m merely asking what did I do wrong? or Does it work Anymore? or I could just be reporting a error.

That error has nothing to do with this tutorial. All this tutorial does is punch a big hole in your NAT through an external program. The only RTE this could create would be the ol’ Address In Use problem.

If you’re getting that error then it’s because of something else you did.

Oh, Ok. Thank you.

For some reason this never works for me…

So it’s actually not a working host?

@Marsh:

I think i tried utorrent to fix it for someone once and you just get address in use errors.

Because µTorrent uses it. Make µTorrent use the port and kill the process, that should work.

Yours faithfully
  Stephan.

ok im sorry for bringing up this month old topic again but i need someone to answer this for me. So i looked in this thread and i saw good and bad replies for this tut. So i use a tutorial based on all its good replies and bad replies (this keeps me from regretting to use a bad tutorial). So i need to know…is this a good way to host a server? Or a bad way? Thank you in advance. P.S: if it is good can somebody give me a download link so i can download Vuze? Thank you in advance…again.

when i do this and then i give my friends the link to my eclipse orgins game runner thingy my friends say that is says missing one or more library files

Tell him to download the runtime files.

he did still got the error

Log in to reply