Game (PicScreen) Resolution

Its easy and it will be done in a few seconds. Remember that you will need a new gui after you change it.

Legend:
x its any resolution you want on horizontal and it should be divided by 32 (800, 1024, 1280, 1344)
Y its any resolution you want on vertical and it should be like the x one divided by 32 (608, 704, 768)

Now that we know the resolution we want lets edit the source:

Client side:
On frmMain, search for Private Sub Form_Load() and add this:picScreen.width = X picScreen.height = YNow go on modConstants , search for ’ Map constants and replace Max_MapX and Map_MapY with this:```
Public Const MAX_MAPX As Byte = (X / 32 - 1)
Public Const MAX_MAPY As Byte = (Y / 32 - 1)

**Server side:**
Go on **modConstants** , search for **' Map constants** and replace Max_MapX and Map_MapY with this:```
Public Const MAX_MAPX As Byte = ( X / 32 - 1)
Public Const MAX_MAPY As Byte = (Y / 32 - 1)

Don’t forget that X and Y are the numbers you want for the resolution and it wont work if you let them as X and Y.
  If you get anykind of errors just delete your maps and it will work fine after that.

so i tried this and everywere you have a x and y i put my res, i start up the server fine, start the client, connect fine, and then it all goes black with the music playing, no error tho.

i also deleted my map in the client folder, but i dont see why everything would go black, i would imagine a missaligned ui but would still see something.  aslo the size of the screen didnt seem to change any.  i went with 1280x1024 so its still a window for me at 1600x1200.

any ideas what i did wrong there?  im new so i dont know much about how this works just yet.

nvrmind i got it working, ty for this.

New to this, and same problem here… How’d you fix it?

Ok, kinda working… I resized my form and my picScreen (btw, I am also using 1280 X 1024) but now the map scrolling is pretty twisted up.

well the maps have to be deleted for it to work, so delete your client and server maps, all of them.

the other thing for me was the in the frmmain on the pic screen make sure the size values are correct.

to get it to stop scrolling in a up/down or left/right when walking on bigger maps you have to set your viewable area slightly larger than your screen res.  so it might end up in you taking it down to say, 1152x864…  its what i ended up going down to so i could have a good ui with it.

hope that helped you out, im new so i dont know alot yet.

That helped out a ton. Thanks  :cheesy:

Were do I place:
picScreen.width = X
picScreen.height = Y

Under which?

Private Sub Form_Load()
    ’ If debug mode, handle error then exit out
    If Options.Debug = 1 Then On Error GoTo errorhandler

’ move GUI
    picAdmin.Left = 544
    picCurrency.Left = txtChat.Left
    picCurrency.Top = txtChat.Top
    picDialogue.Top = txtChat.Top
    picDialogue.Left = txtChat.Left
    picCover.Top = picScreen.Top - 1
    picCover.Left = picScreen.Left - 1
    picCover.Height = picScreen.Height + 2
    picCover.Width = picScreen.Width + 2

’ move GUI
    picAdmin.Left = 544
    picCurrency.Left = txtChat.Left
    picCurrency.top = txtChat.top
    picDialogue.top = txtChat.top
    picDialogue.Left = txtChat.Left
    picScreen.width = X
    picScreen.height = Y
    picCover.top = picScreen.top - 1
    picCover.Left = picScreen.Left - 1
    picCover.height = picScreen.height + 2
    picCover.width = picScreen.width + 2

or just click on the picScreen (picturebox) and find the height: / Width: in the properties of it.

Thank you! ^^

i cant seem to get this to work

ive opened eclipse with vb6 and delete/copy/pasted everything u said and saved project and saved with ctrl5

when i open my server and client up and run them its as if nothing happend

i even deleted my maps first

i cant seem to get this to work

ive opened eclipse with vb6 and delete/copy/pasted everything u said and saved project and saved with ctrl5

when i open my server and client up and run them its as if nothing happend

i even deleted my maps first

Did you change the X and Y to your desired resolutions?

i put

Public Const MAX_MAPX As Byte = (1280 / 32 - 1) Public Const MAX_MAPY As Byte = (1024 / 32 - 1) in server and client right where

Max_MapX and Map_MapY was located in **modConstants

and i added**

picScreen.width = 1280

picScreen.height = 1024

into

’ move GUI

picAdmin.Left = 544

picCurrency.Left = txtChat.Left

picCurrency.top = txtChat.top

picDialogue.top = txtChat.top

picDialogue.Left = txtChat.Left

picScreen.width = 1280

picScreen.height = 1024

picCover.top = picScreen.top - 1

picCover.Left = picScreen.Left - 1

picCover.height = picScreen.height + 2

picCover.width = picScreen.width + 2

in Private Sub Form_Load()

where did i mess up should i post the code from vb6 to let u look at it ?

didnt mean to post this twice Public Const MAX_MAPX As Byte = (1280 / 32 - 1)

i cant seem to get this to work

ive opened eclipse with vb6 and delete/copy/pasted everything u said and saved project and saved with ctrl5

when i open my server and client up and run them its as if nothing happend

i even deleted my maps first

Client!

frmMain


Private Sub Form_Load()

    ' If debug mode, handle error then exit out

    If Options.Debug = 1 Then On Error GoTo errorhandler

    ' move GUI

    picAdmin.Left = 544

    picCurrency.Left = txtChat.Left

    picCurrency.top = txtChat.top

    picDialogue.top = txtChat.top

    picDialogue.Left = txtChat.Left

    picScreen.width = 800

    picScreen.height = 600

    picCover.top = picScreen.top - 1

    picCover.Left = picScreen.Left - 1

    picCover.height = picScreen.height + 2

    picCover.width = picScreen.width + 2

    ' Error handler

    Exit Sub

errorhandler:

    HandleError "Form_Load", "frmMain", Err.Number, Err.Description, Err.Source, Err.HelpContext

    Err.Clear

    Exit Sub

End Sub

modConstants


' Map constants

Public Const MAX_MAPS As Long = 100

Public Const MAX_MAPX As Byte = (800 / 32 - 1)

Public Const MAX_MAPY As Byte = (600 / 32 - 1)

Public Const MAP_MORAL_NONE As Byte = 0

Public Const MAP_MORAL_SAFE As Byte = 1

Server!

modConstants


' Map constants

Public Const MAX_MAPS As Long = 100

Public Const MAX_MAPX As Byte = (800 / 32 - 1)

Public Const MAX_MAPY As Byte = (600 / 32 - 1)

Public Const MAP_MORAL_NONE As Byte = 0

Public Const MAP_MORAL_SAFE As Byte = 1

This works for me completely once I delete the map files in the client and server side (not the folders) and the accounts (once more, not the folder)

it still didnt work maybe im doing sumthing rong when saving it

how do you save it in vb6 i used ctrl5 that time should i click save project insted ?>

i deleted all accounts and maps from folders then copy and pasted you code in and when i start it up its still normal like nothing ever happend

do you know if this works for eclipse event eystem ? cuz thats what i have downloaded at this time

maybe im trying to do the rong thing here… im trying to change my game to fullscreen is this the right tutorial?

im sorry im such a noob i dont know if resalution is screen size lol

i think it is tho right lol

Well when you’re finished with both you go to file then click:

For Client:

make Eclipse Origins.exe

For Server:

make Server.exe

now i get compile error

only comments can be posted after end sub, end function or end property

and errorhandler is hilighted in vb i put a line under the highted one on this post

Private Sub Form_Load()

’ If debug mode, handle error then exit out

If Options.Debug = 1 Then On Error GoTo errorhandler

’ move GUI

picAdmin.Left = 544

picCurrency.Left = txtChat.Left

picCurrency.top = txtChat.top

picDialogue.top = txtChat.top

picDialogue.Left = txtChat.Left

picScreen.width = 800

picScreen.height = 600

picCover.top = picScreen.top - 1

picCover.Left = picScreen.Left - 1

picCover.height = picScreen.height + 2

picCover.width = picScreen.width + 2

’ Error handler

Exit Sub

errorhandler:

HandleError “Form_Load”, “frmMain”, Err.Number, Err.Description, Err.Source, Err.HelpContext

Err.Clear

Exit Sub

End Sub

errorhandler:

HandleError “Form_Load”, “frmMain”, Err.Number, Err.Description, Err.Source, Err.HelpContext

Err.Clear

Exit Sub

End Sub

now i get compile error

only comments can be posted after end sub, end function or end property

and errorhandler is hilighted in vb i put a line under the highted one on this post

Private Sub Form_Load()

’ If debug mode, handle error then exit out

If Options.Debug = 1 Then On Error GoTo errorhandler

’ move GUI

picAdmin.Left = 544

picCurrency.Left = txtChat.Left

picCurrency.top = txtChat.top

picDialogue.top = txtChat.top

picDialogue.Left = txtChat.Left

picScreen.width = 800

picScreen.height = 600

picCover.top = picScreen.top - 1

picCover.Left = picScreen.Left - 1

picCover.height = picScreen.height + 2

picCover.width = picScreen.width + 2

’ Error handler

Exit Sub

errorhandler:

HandleError “Form_Load”, “frmMain”, Err.Number, Err.Description, Err.Source, Err.HelpContext

Err.Clear

Exit Sub

End Sub

errorhandler:

HandleError “Form_Load”, “frmMain”, Err.Number, Err.Description, Err.Source, Err.HelpContext

Err.Clear

Exit Sub

End Sub

It’s because you can only have one error handler.


Private Sub Form_Load()

	    ' If debug mode, handle error then exit out

	    If Options.Debug = 1 Then On Error GoTo errorhandler

	    ' move GUI

	    picAdmin.Left = 544

	    picCurrency.Left = txtChat.Left

	    picCurrency.top = txtChat.top

	    picDialogue.top = txtChat.top

	    picDialogue.Left = txtChat.Left

	    picScreen.width = 800

	    picScreen.height = 600

	    picCover.top = picScreen.top - 1

	    picCover.Left = picScreen.Left - 1

	    picCover.height = picScreen.height + 2

	    picCover.width = picScreen.width + 2

	    ' Error handler

	    Exit Sub

errorhandler:

	    HandleError "Form_Load", "frmMain", Err.Number, Err.Description, Err.Source, Err.HelpContext

	    Err.Clear

	    Exit Sub

End Sub

like that

Log in to reply