Unable to log in

I just recently bought myself a new computer, and downloaded EO 4. I have a gold licence, but whenever I tried to sign into the server it said “account not found password/licence incorrect.” I know for a fact that I’m typing in the right information, however, I am unsure of what to do. Anyone have any ideas? Thanks in advance.

What OS does your new computer use?

Windows 8.

Is that the problem?

Nope, you should be able to connect with windows 8. Have you allowed the server through your firewall, etc.?

My firewall is set to allow it through, but it still doesn’t let me log in. Getting the same error.
Any ideas?

Are you even running the server…?

Nope, not sure what it could be. What is the error? Is it saying that your details are incorrect? Or is it saying something different? And does it still work on your other computer?

At the bottom of the server login it says “Account not found or password/licence incorrect!” Not window appearing or anything. It works fine on my old computer. I logged in with no problem, and logged out, thinking it could’ve been the fact that I was trying to log in on two different machines. Still won’t let me on.

Must be the way they have the server set up. Wait for an admin to respond to this thread I hope they can help you out.

Alright, no problem. I’ll just work on planning out quests in the meantime. Thank you for trying to help. 🙂

The licensing goes manually , so the dev havent checked his mail for new pays.

You just need to wait a bit till dev sets your account to gold(manually).

Oh I’ve had my licence for awhile. Bought EO4 when it first came out. I’m just trying to get it on my new computer.

Log in to reply