Map, client crash

I can’t teleport or walk in some maps. The game client crashes and the server shows four errors.  This all started after I updated eclipse origins.

Error 1:

The following error occured at ‘Form_Load’ in ‘frmLogin’.
Run-time error ‘9’: Subscript out of range.
Error occured on line 0

Error 2:

The following error occured at ‘UpdateMapBlock’ in ‘modServerLoop’.
Run-time error ‘9’: Subscript out of range.
Error occured on line 60

Error 3:

The following error occured at ‘InitServer’ in ‘modGeneral’.
Run-time error ‘401’: Can’t show non-modal form when modal form is displayed.
Error occured on line 1460

Error 4:

The following error occured at ‘WriteBytes’ in ‘clsBuffer’.
Run-time error ‘9’: Subscript out of range.
Error occured on line 40

I hope someone gives me an explanation for this. 🙂

Not really an explanation… Will you upload a map or two that generally causes this crash? The maps are located in the Server/Data/Maps folder.

Map 1:

[Events]

EventCount=0
[Event1]
Name=
Global=0
x=22
y=9
PageCount=1
[Event1Page1]
chkVariable=0
VariableIndex=0
VariableCondition=0
VariableCompare=0
chkSwitch=0
SwitchIndex=0
SwitchCompare=0
chkHasItem=0
HasItemIndex=0
HasItemAmount=1
chkSelfSwitch=0
SelfSwitchIndex=0
SelfSwitchCompare=0
GraphicType=0
Graphic=0
GraphicX=0
GraphicY=0
GraphicX2=0
GraphicY2=0
MoveType=0
MoveSpeed=0
MoveFreq=0
IgnoreMoveRoute=0
RepeatMoveRoute=0
MoveRouteCount=0
WalkAnim=0
DirFix=0
WalkThrough=0
ShowName=0
Trigger=0
CommandListCount=0
Position=0
QuestNum=0

Map 2:

[Events]

EventCount=0

Will you also upload the corresponding .dat files for us? Any file hosting site should do, like www.mediafire.com That is what actually contains the tile info.

Thanks 😄

Log in to reply