HELP! First time Eclipse user, about to gouge his eyes out!

Before reading: I am running Windows 7 64-bitAlright it’s my first time using Eclipse, and this is how far I’ve gotten,

I downloaded Eclipse Library Files, Installed them, seemed to work okay. Then I downloaded Eclipse evolution 2.7 (all this was done using a guide and was unzziped using winrar). I unzipped it then tried to run Server and editor (at different times) but always get the same ERROR when I try to run either one!

Server - Component ‘MSCOMCTL32.OCX’ or one of its dependincies not correctly registered: a file is missing or invalid

Editor - Component ‘COMDLG32.OCX’ or one of its dependincies not correctly registered: a file is missing or invalid

I see it says to register files (in the guide) BUT when I right click any of those files there is no option to register any of them (in the Data folder) and when I try to drag them to RegSvr32.exe I get an additional ERROR:

The Module
“C:\Users\xxx\Desktop\Eclipse-Evol…\Richtx32.ocx”
was loaded but the call to DllRegisterServerfailed with
error code 0x8002801c.

I have no idea how to fix ANY of this and have searched google and bing with little to no help, so I tried before posting this, can’t blame me.
Any help would be appreciated, thanks!

Again, I’m running Windows 7 64-bit and using Winrar to un-zip downloaded files.

Try installing the Eclipse Library Installer 9.12.17.
(You did this).

Installing ELI on Windows Vista and later.
(Make sure you ran this as an administrator).

If that doesn’t work, feel free to post again.

@Soul:

Try installing the Eclipse Library Installer 9.12.17.
(You did this).

Installing ELI on Windows Vista and later.
(Make sure you ran this as an administrator).

If that doesn’t work, feel free to post again.

Or uninstall then reinstall the lib files
Then feel free to gouge your eyes out ;D

Did not work, but thank you.

Side notes:

as far as the guide goes my background for the installer was just grey, no picture, and it didn’t work, and I already did this.

But I appreciate the help.

Still fishing for an answer

Alright, so just to make sure you did install the 64 bit library files right? and not the 32?

If you did use the 64 bit files right clicked and hit run as a administrator try these instead: http://www.freemmorpgmaker.com/ELIS.exe

Also i would suggest trying Eclipse Stable or Origins they are newer versions.

Please, gouge your eyes out, as did I when I was getting Eclipse to work xD (Surprisingly, I can still see.)
Drag each individual .dll/.ocx over regsvr32. If it errors, skip it, if the server/client doesn’t work because of one of the one that had an error, try registering it again. If it gives the error again, wait a while, try again.

That’s what I did, and all versions of eclipse work fine for me ^^
~Urame

Log in to reply