[evb 2.2.1] RTE 380

whenever i open the game and click an item in the item editor i get rte 380 referring to


frmEditor_Item.scrlAnim.value = .Animation

what should i do

Sum tin wong… If its blank copy without your edits, try to delete animation folder in server., or animation and item folder, there is smtn about maybe some item rec have been modified.

i just tried that it still did that

RTE 380 means that the value you have set is out of bounds of that of the control. Here is the documentation.

Make sure that value of .Animation is not greater than MAX_ANIMATIONS. (Or whatever is the max value of scrlAnim.)

Sum tin wong… If its blank copy without your edits, try to delete animation folder in server., or animation and item folder, there is smtn about maybe some item rec have been modified.

How would that fix the problem? Only the number of the animation is required, so nothing would be changed if you delete your animations. If the item recs weren’t the same, only a RTE 9 would come up, and that would be upon saving the item, not clicking the lstIndex.

RTE 380 means that the value you have set is out of bounds of that of the control. Here is the documentation.

Make sure that value of .Animation is not greater than MAX_ANIMATIONS. (Or whatever is the max value of scrlAnim.)

Pretty sure if it’s out of bounds, it’s RTE 9. RTE 380 is like assigning a “true” value to a variable that’s a long.

You’ll want to make sure that scrlAnimation is a scrollbar, and that in the Item rec, the Animation variable is a long.

thanks for the help but as its currently a basically unmodified engine ill just reinstall

thanks for the help but as its currently a basically unmodified engine ill just reinstall

Alright, but if it’s unmodified, it would be nice to solve another bug.

that didn’t work so my latest idea is the items created when refreshed require an animation that doesn’t exist

EDIT: this seems to be it ill leave this as unresolved until i know that this is why it happens

Log in to reply