Guilds in 4.02

hello all, i am new to eclipse and i am sorta familiar with programming. i am using version 4.02 and it seems to have most of the basic functions that i would like to start out with except a guild function i am sure there is a way to implement this i am just not sure as to how.

if anyone could help me out would be greatly appreaciated!!!

Version 4.02? Which engine are you using? There are tutorials on implementing a guild system in the tutorial section. You can try using the search bar to find it! ^_^

i tried search bar just with guilds nothing came up
i am useing eclipse orgins one off there site.

He is talking about JC Denton Denton’s version.

RebelGames you got the engine off the other site then ask there not here.

http://www.touchofdeathforums.com/community/index.php?/topic/124848-eo-2030-guilds/

If you know a bit of programming shouldn’t be much an issue adding this to any eclipse based engine.

http://www.touchofde…eo-2030-guilds/

If you know a bit of programming shouldn’t be much an issue adding this to any eclipse based engine.

The engine he is talking about is closed source.

The engine he is talking about is closed source.

Well nvm than thanks for pointing that out haha

EclipseOrigins.com isn’t affiliated to TouchOfDeathForums.com

You have a problem with their engine post a topic over there.

Well nvm than thanks for pointing that out haha

I suggest you use the official engine that we have here. It’s completely open source! ^_^

Offtopic: SCOTT!!! :D

ahh thank you guys i see what you mean :3 so the link that he provided will work for the version on this forum. correct?

thanks again for being patient with me lol

ahh thank you guys i see what you mean :3 so the link that he provided will work for the version on this forum. correct?

thanks again for being patient with me lol

Yes.

Ok next noob question lol, i finished editing the code for the guild yet when i try and make server.exe i get a error code saying

compile error:

method or data member not found

' Get the listening socket ready to go

frmServer.Socket(0).RemoteHost = frmServer.Socket(0).LocalIP

frmServer.Socket(0).LocalPort = Options.Port

' Init all the player sockets

Call SetStatus("Initializing player array...")

For i = 1 To MAX_PLAYERS

Call ClearPlayer(i)

Load frmServer[color].Socket[/color](i)

Next

.socket is highlighted.

I have no idea how to fix this like i said fairly new to programming yet i want to learn it all 😜

any help on this thanks

Goto your References and add in Winsock Control 6.0

The reason you have this error is because you were using the portable version which doesn’t load any references(from what i can remember….don’t quote me on this!!!) and all you need to do is add the reference and add the component onto frmMain again

i dont have that in my refrences

Install This. that will install the required files in order to open this source.

EDIT: i meant to say Right click where all the items are

And then click Components then look for the Winsock Control.

its still not coming up with winsock control

you rly don’t have this?

ohh i was looking under the W’s not microsoft i do have it and it was allready checked

Is the object there on the little menu with all the other components? if so, select it and add it to frmMain.

i selected im not understanding what you mean by add to frmmain

Log in to reply