Dx8vb.dll was not found

Everytime I try to open my client on my Vista it says “This application has failed to start because dx8vb.dll was not found. Re-installing the application may fix this problem.”

I don’t know how to fix this o.o

Install the run times for the engine that you are using. Depending upon the bit size of your operating system, install them in System32 or SystemWow64

install the libraries: http://www.mediafire.com/?186klkgqojhw9qr

that’s a mirror that i created of the original Libraries for nightly Eclipse

Install as admin, then try if it worked (if don’t, restart your computer and try again)

didn’t work :c

Try manually registering the DLL.

Depending on whether you’re on a 64-bit or 32-bit machine, you’ll either have to install it in _\SysWOW64_ or \System32.

If you have the run-times installer, make sure you’ve ran it as an administrator.

If that doesn’t work, on Vista run “regsvr32 dx8vb.dll” without quotes (just use windows key + r). You will need administrative access to install a dll.

[attachment=811:Flamingo.jpg]

what it sayss

That’s odd… I have a 64 bit and they are in System32 and the engine still works…

try this:

1. go to C:\Windows\System32 (or C:\Windows\SysWOW64)

2. find the file “Regsvr32.exe”

3. duplicate the system32 window folder (Ctrl+N)

4. find dx8vb.dll (it should be in the same folder where you found the other file)

5. drag and drop the .dll into regsvr32.exe

6. test (if didn’t work, try to find it in the other folder. If you used system32 folder, try doing the same with the sysWOW64 folder.)

He doesn’t have the dll to start of with.

ok i fixed it :D

Edit main post, change tag to resolved.

Log in to reply