Equip than crash

Hello, i was in the mid of creating an item, i created an armor item, i than placed it on the ground equiped it an than the game crashed an every time i log back on it crashes, what can i do to fix this?

THanks!

Delete your character. That will stop the crashing when you log in. As for the item, maybe you forgot to adjust some stats and it crashed?

Okay that worked, but again on certain items i create than equip the game just crashes an than i have to delete the character again

Try deleting all the items in the server data folder.

What engine are you using ?

Shot in the dark, but you might be getting an RTE9 somewhere with your equipment data because you have a ITEM_TYPE_NONE equipped in your armour slot. If it crashed when you equipped it before saving the new item, the data would have reset to a blank item. There isn’t really a fix for this other than adjusting your behaviour.

To avoid errors, always save any item before using it. Never use an item you’re editing with the item editor still open, or if you suspect a fellow developer is editing or about to edit that item.

If you are saving the items and closing the item editor before using them, then you are not at fault and the engine you are using has a pretty big bug.

Delete your character. That will stop the crashing when you log in. As for the item, maybe you forgot to adjust some stats and it crashed?

Uh, no? That’s a band-aid solution for something that might be more serious. Sure, he could have forgotten to delete his players/items after putting in an edit, but a doctor examines the patient before making a diagnosis. You don’t know what line is causing the error, nor what kind of error is popping up.

Hockeylova, please include what line of code is crashing the engine if you have VB6. If you don’t have VB6, what kind of error is crashing the server?

Knowing what engine you’re using is rather helpful as well.

Log in to reply