Custom Tilesets

Hey, I downloaded a couple of custom tilesets from different forums, I have put them in-game but the background color shows up when I use them

e.g I try to add a desk but the green background color shows up with it…

Any suggestions what to do???

Any advice will be appreciated, much thanks!

top left square should be the same color (ie this will be your transparent color)

it will translate that color to invisible, so in case of your desk, the top left pixel of the tileset should be that color of green

(it might be possible you have a mix of color, than you have to recolor your image)

the left top square should be only your mask color, so in your case, green, because the engine uses that to determine which color to make see tru :)

for duck sake… unnown, stop ninja-ing me xd

lol sorry, i’ll go on my break now, have fun ^.^

lol, its cool :)

Im not sure I understand what you mean top left square, the top left square is apart of the tileset it has a grass patch there….

and that’s the problem, it should be the transparent color

look at how the normal tilesets are done.

top-left square is always a set color which is used for transparancy

Does it have to be the SAME color on every tile set or just the first one?

every tileset can have it’s own color i believe, just try it out and see what happens :D

Nope, I set the top left tile to white and nothing still green background….

yes, because white isn’t green =P

if you set it to white, all white will become transparent

Dude, it has to be set to GREEN. Becuase green is around ALL your tiles, so the VERY first pixel of the image has to be the color of the rest of the background. So make it green, not white.

See? The top left is left black because the background is black, and you dont want black to show up around the items, so they left a 32x32 black box, although it just needs to be the first pixel, I believe.

EDIT: duck you unnown

Ok PLEASE tell me what im doing wrong, I followed EVERYTHING but still doesnot work…

LOOK: http://tinypic.com/r/30xj2wo/6

Have you restarted your client after you saved the tileset?

yup

hang on ill try again…

The VERY top corner.

Like that. Post your entire tilesheet.

So many replys and no one know why…

If you are not using DX8 then will it never be working… the tileset which you use got transparency what means the thing around it theres an transparent color which makes the first tile-color darker = not removed anymore

what does that mean ? -> Remove the transparency from your Tileset and it will work but the tileset will look bad then maybe…

So many replys and no one know why…

If you are not using DX8 then will it never be working… the tileset which you use got transparency what means the thing around it theres an transparent color which makes the first tile-color darker = not removed anymore

what does that mean ? -> Remove the transparency from your Tileset and it will work but the tileset will look bad then maybe…

What are you talking about? His tileset contains no transparency whatsoever.

I think what MA means is, delete the now “green background color” into a transparency. This easily done with Gimp or an art program of your preference.

Log in to reply