Game runs faster on server host…

Does anyone else have this problem? On my brother’s computer the movement speed is hella slow, while on mine the character moves fine.

This is obvious. Your obviously not going to have problems as far as connection goes, because your client is literally on the same computer as the host. If your brother is lagging that bad, then you have a bad internet connection, a better host will help. I know that Eclipse has some memory problems in the source, as far as too many players go so maybe you could look into that.

No, as in the game physically runs slower; it’s not a problem with lag. Everything happens slower (for example, the movement from one tile to another takes 2 seconds instead of 1).

People have always stated that running the server and client on one computer will cause issues with lag ect. Using a nice uptodate host/server comp will help a lot. I can use server and up to 4 clients at the same time without issues, and connect with my wifes laptop for testing purposes and have no issues, True issues will be shown with a external connection. One thing i dislike is the jumping and “teleporting” of characters… but that’s always been an issue with Eclipse and older engines.

Edit:

The server eats resources and starts to compete with the client on inadequate computers.

People have always stated that running the server and client on one computer will cause issues with lag ect. Using a nice uptodate host/server comp will help a lot. I can use server and up to 4 clients at the same time without issues, and connect with my wifes laptop for testing purposes and have no issues, True issues will be shown with a external connection. One thing i dislike is the jumping and “teleporting” of characters… but that’s always been an issue with Eclipse and older engines.

Edit:

The server eats resources and starts to compete with the client on inadequate computers.

Not to mention the server is probably hosted on a computer that’s…not the best for hosting. Its probably a family or personal computer that’s littered with other things.

Not to mention the server is probably hosted on a computer that’s…not the best for hosting. Its probably a family or personal computer that’s littered with other things.

have to agree, Youre better off getting a purpose built server or pay someone to host it on a good server. Running it on a bog standard computer will not help you in the long run.

I retested, and it’s not a problem with the server client on the same computer at all, sorry for the confusion. On one computer, the client runs faster than on the other computer, and this causes the fast client to be able to cause the player to move faster than players on the slower client.

And this goes to all people, I remember running the Legends of Alzalga server on a 200 dollar computer, only 2 GB of ram, and I could hold 20+ players no problem, which is a big deal in the Eclipse community considering player count never comes close to that.

I have to disagree with you finally CMF :P, i had over 30 players on a Elysium game many years ago (average online player count was 10-13) the server was buggy to hell no one back then fixed anything and i was using a custom version from Pingu. Still the problem remains that new computer handle the client fine older computers (like any game?) struggle. The problem your having is what happens in any game? packet loss maybe? not sure never had this problem. My wife’s old laptop that was a crock of sh## ran Eclipse fine so i would have to say sounds like one computer is really out of the ark?

or packet loss? Change the max FPS of the engine for the laggy computer and see if that helps?

The problem is not with the connection, it’s with the client; on one computer it runs much faster than all the others.

Anyone?

Anyone?

The computer it runs on may not meet the minimum specs.

Have you tried trouble shooting 101 and ran the client on a … Third computer?

Is the issue isolated to just your brothers computer.

Will it run “hella” slow on a third computer ?

Are you connecting via LAN or wan?

What’s your net connection?

What’s your server specs?

What’s his laptop specs?

You don’t really know if you have an issue until you try it on more computers and sender those questions.

Simply thinking something is wrong with the client doesn’t mean their is… Actually you already said nothing is wrong with the client as it runs fine on your server .

Until you run more test you won’t get any help.

Right now it’s like me trying to run bioshock on my wife’s netbook and saying the games the issue when it fails to run

Yes, I have; I think the problem isn’t that it runs slow on other computers, it’s that it runs fast on mine; my brother and I have the same laptop.

Same hardware really doesn’t mean anything go and answer each of my questions separately otherwise you are asking us to wild guess

Log in to reply