Plz help

i have looked all over forum for answers and tryed wat people have suggested but nothing has worked so far. I keep getting a richtxt.ocx error in vb6 so i cant compile anything and it says object library not registered every time i start it up. Here is were i have the error every time i try to compile private mRTB As RichTextBox and right here frmMain.txtChat.SelStart = Len(frmMain.txtChat.text) and i get this error when tryign to compile server Class MSComctlLib.ListView of control lvwInfo was not a loaded control class… Thx for looking and plz help.

Did you install the run time files?

yes

Are you using a client that requires Dx8?

I have tryed all clients mirage realms all the custom ones robins main one everything still the same for each. I start up my vb with the client file in the source and first thing that comes up is object Library not registered then i hit ok then it says do you wish to contiue loading i hit yes then it says error during load pls refor to frmmain.log for details so i do that and this is wat it says Line 1685: Class RichTextLib.RichTextBox of control txtChat was not a loaded control class. no matter which custom client i load or any thing i tryed the library files i tryed the sp6 nothing seems to fix it. I ran as admin in xp sp2 i tryed all that so far nothing. regsrv32 richtxt.ocx and still same thing.

O’k maybe it needs a missing file, try downloading each of these.

Put that beside your eclipse client exe

Dx8 DLL - http://up.ht/15z4Ns5

Run the installer

Runetime Installer - http://up.ht/Y3kEzB

Now tell me if this fixed it or not

I think it might be my riched20.dll and my riched32.dll they wont register.

I don’t know if that will work. That’s only to get your client to actually load if it won’t. I don’t know how to fix the code if thats problem you still getting. As I’m new to coding in vb6

KK well did you try what I told you?

O’k try this. Open CMD as administrator and type this code in:

Regsrv32 %windir%\system32\riched20.dll /i

Now do that same for the other one:

Regsrv32 %windir%\system32\riched32.dll /i

If that dosen’t work then go to this dirrector. %windir%\system32\

And if you cant find the dlls there. Then that means you don’t have them

yeah still the same thing

[EDIT] - Then just try re downloading these and over-right them with existing. But remember to keep a back up just incase.

If you don’t have them then you can download the riched32.dll here - http://www.dll-files….zip?0WIfWCZFmU

riched20.dll here - http://www.dll-files….zip?0WIfWCZFjW

And put that in this dirrectory %windir%\system32\

Stop using VB6 portable. Use the enterprise edition. The portable version compiling Eclipse will give errors. It doesn’t have the required files.

You need enterprise edition. Try looking it up on 4shared to find it. Or buy it.

I have enterprise edition.

~~Uninstall it. Uninstall runtimes. Then install it again, making sure you run the installer in Windows XP Pack 3 Compatibility mode, while running as administrator. Then install first the DX7 runtimes, then the DX8 runtimes. Heck, if that doesn’t work. I don’t know what to tell you.

I’ll try lurking around the internet.~~

https://groups.google.com/forum/?fromgroups=#!topic/microsoft.public.vb.general.discussion/0s9tmxzUxsI

Look at that.

Lol, Yeah if your using portable then thats another possibility why.

Ye Kem, I gave her the Dx8 Runtimes and the dll. And if non of this works, then I just say download clean EO and just start working on your own version.

The clean eo gives me the same problem. That is why on came on here for help.

Log in to reply