Messed up class only??

When I make a spell for class only for example I make a wizard spell, and then make the item so the person can learn the spell. I make a wizard and get the item but then it says this is for warriors only? I then check and it says that both the item and spell says Wizard. ???

This is a known bug. Not sure if there is a bug fix tut for this. But check out the Tutorial -> Source -> Bug fixes board.

Thanks! I thought it was something I did horribly wrong. Haha!

if u cant find a tortorial then make the opeste put the spell for warrior and it will me for the magicen

I just fixed this myself lol. Robin accidentally had two important statements in the wrong place. No worries. Not a problem. The class box SHOULD have a ‘None’ option. But it doesn’t, and I’ll show you why. In Client>modGameEditors>SpellEditorInit change this code:


' build class combo

.cmbClass.AddItem "None"

.cmbClass.Clear

to


' build class combo

.cmbClass.Clear

.cmbClass.AddItem "None"

The ‘None’ option was added but then immediately removed. Without the ‘None’ option, your selection is returning the wrong index. so if you have:

Warriors

Wizards

and you select Wizards, it’s going to return that you selected Warriors because it doesn’t account for the missing ‘None’. Hope this is understood. I believe this will solve your problem… Did for me.

The topic is about 15 days old

The topic is about 15 days old

AND STILL its unsolved, so the guy posted the fix did right eh? preatty helpful for others that has the same issue.

Which engine was this for?? CS:DE?

Which engine was this for?? CS:DE?

I believe for all engines.

I made the fix in EO - Event System 2.3 to be exact. This doesn’t mean the same backwards code isn’t in any other versions though. I also threw this little fix into a tutorial quite like my post after replying to this topic.

Log in to reply