Problems with server

I’m not able to change the IP of my server, because in my file “Config” does not have the IP line with this, the server automatically search the ip of my router and not my hamachi. How to solve?

Server:


[OPTIONS]

Game_Name=Testando

Port= 7001

MOTD=Bem vindo ao teste

Website=www.teste.com.br

The IP is only needed to connect to the server. You should find it in the Client side.

I did change the client ip does not work more because the client ip’s with my hamachi ip for testing, since the server is connecting to the ip of my router. Do not have any way to change this on the server? he is always connecting with the ip of a “Local Host”.

Do you not have a ip address line in your client config? Idk why you are looking in your server config… Using hamachi is a bad idea anyway, learn how to portforward, im sure there are tuts on the forums somewhere.

Make ‘He’ go to data files\config.ini and find IP and change it to the Hamachi network IP. Also make sure that ‘he’ has downloaded Hamachi and has joined your network.

I already changed the client ip to my hamachi, and it did not work … because if the server continues with the opening ip (localhost), the client will never get access. Of all the servers that already edited, this eclipse origins is the one who does not have the option to select the ip.

Also make sure that ‘he’ has downloaded Hamachi and has joined your network.

If you’re going to host a server with hamachi make sure that you can do so.

First thing is first, create the network and have the player(s) join said network.

Then you go into the data files\config.ini and change the IP to the hamachi id.

After that you send them over that config, then start the server. You might also

want to make sure they have the same port or you’ll never connect. For you, you just keep

it as localhost. If you follow these steps correctly, the person should be able to connect.

Log in to reply