Problem loading Server.vbp [RESOLVED]

Hi guys,

So I’m having a problem when trying to load Server.vbp file. It’s showing me these 2 errors :

Why are u using a virtual PC?

Because VB6 is’nt working on Windows 7

Maybe that might be the reason.

I don’t think so, because I tried loading not modified EO Server.vbp file and it’s fine.

Read the log file. That might give clues. And also try re-extracting the file.

This line is in log file - " Line 198: Class MSComctlLib.ListView of control lvwInfo was not a loaded control class. "

Delete source and try again. Most probs ur source is corrupted.

did you try installing the runtime files on the virtual pc?

Yes, but problem is still here

vb6 work on win 7 and win 8: )

If u installed the runtime files after getting this error for the first time the code is corrupt. Try deleting and reinstalling the source.

@Adiff ofc it works. Windows will support it.

http://www.fortypoun…asp?artid=20502

You can thank me later

Thanks I have installed in on W7, but still same problem

I have my vb6 installed and running fine on my Windows 7, maybe you should reinstall vb6

You guys are forgetting the one issue with Windows 7 and its security…

Go into the Start menu, locate the Visual Basic.exe file IN the start menu…Right click and click on Run as Administrator

Growlith1223 - I tried doing this but still same

Slasher <>,…,<> - I think problem isn’t in vb6, because it opens EO with no code edited fine

If u installed the runtime files after getting this error for the first time the code is corrupt. Try deleting and reextracting the source!

I know that this topic is a bit old but you didn’t update the post if you have it working or not. If you do nice I would like to post another solution to this problem if someone else runs across the same issue.

Open you .vbp file in notepad and find this line.

Object={831FDD16-0C5C-11D2-A9FC-0000F8754DA1}#2.0#0; MSCOMCTL.OCX

See the 2.0 in that line if it is 2.0 on yours as well then change it to 2.1

If you have 2.1 then change it to 2.0 or if you don’t want to guess check the ocx version that is currently installed but the most common versions are those two then just save the notepad and open your project the regular way.

Good Luck

I already posted this somewhere else try that.

To install vb6 on windows 7, run it with elevated privileges or disable UAC for the installation process.

To fix your error, it’s refering to a missing or corrupt Mircrosoft Common Controls SP6 active x control.

You can try to regsvr the file and see if that fixes your issue

On win xp

1. Start

2. Run

3 type in regsvr32 /u mscomctl.ocx

On win 7

1. Stat

2. Type in cmd

3. Right click cmd and run as admin

4. Change directory to your windows\syswow64 directory

5. Then regsvr32 /u mscomctl.ocx

Log in to reply