Upgrading Server?

Hey guys, so I’m kinda stumped and need help.  My friend recently sent me the source code for a game he wrote in 2009, using the Eclipse Stable Edition Server.  I wanted to start working on the project again and to progress it forward.  However whenever I try to run the server I encounter an error.

At first I had to update my libraries for the mscomct.ocx (I think that was the file name), so I did that, I then registered the file through my cmd prompt, and it said successful.  However when I try to turn on the server I am getting an error “error loading script engine”.  I did my own research on this and from what I gathered, it appears the server was written for a 32 bit computer and I have a 64 bit.

So of course, I set off to search for the 64 bit version of Eclipse Stable Edition Server but was rather unsuccessful.  Is there a 64 bit version floating around somewhere in cyberspace or was it never created?

If the ladder is the answer (there is none), is there a way to upgrade the server into a newer version that is compatible with Windows 7 64 bit?  When I say upgrade, I mean to switch servers over but to still use the scripts and maps that I already have that work with the Stable Edition, or if I changed the server if I’d have to start from scratch?

We haven’t supported Eclipse Stable for quite some time, but since you question relates to all versions of Eclipse, I’ll answer it anyway. VB6 is inherently 32-bit. 64-bit simply didn’t exist at the time.

First, make sure that you run in compatibility mode for XP SP3. Then, install the runtime files (I’m not sure if you can find Eclipse Stable’s somewhere, best of luck on that!). Make sure you do all of this as an administrator.

Thank you, I appreciate the reply.  Do you know if there is a way to possibly use the scripts/maps/configs etc from stable in the new one.  I have no problem upgrading, it’s just I have a lot of work already completed for stable and would be a shame for it all to be useless

@Daikonran:

Thank you, I appreciate the reply.  Do you know if there is a way to possibly use the scripts/maps/configs etc from stable in the new one.  I have no problem upgrading, it’s just I have a lot of work already completed for stable and would be a shame for it all to be useless

Unless you want to write a converter, no.

Darn =/ Well thanks for your time, it’s unfortunate none of it can be salvaged.  I guess it’s time to start from scratch

@Daikonran:

Darn =/ Well thanks for your time, it’s unfortunate none of it can be salvaged.  I guess it’s time to start from scratch

Before you give up, look around the forums and check out the converters that are lying around. See if you can rewrite one to transfer from Stable to Origins.

Stable support ended quite a while ago so there’s really no one who can give support for it.

Log in to reply