White screen

Seem to be having an issue. After I  log in, I just get a white screen. I can type into global chat and it appears in the server log which is real strange.

Any ideas?

Literally no one can help you unless you specify what version of eclipse you are using.

Oh my bad. It’s Skywyre Primitive V8

Thank you, now that you have said that, your issue is with a line of code inside the engine on the client that does this flashing type thing, it checks GetTickCount, however since the value is within the negatives, it doesn’t remove the white texture being applied.

If FlashTimer > GetTickCount Then RenderTexture Tex_White, 0, 0, 0, 0, frmMain.ScaleWidth, frmMain.ScaleHeight, 32, 32, -1

It would be this line here under sub Render_Graphics, i really haven’t figured out why it’s there so i usually just comment it out

That worked, thanks. It’s odd because I didn’t change anything, I loaded up the source after about a week of not doing anything to it and had this problem. Is it not something to do with weather? I’ll have to check to make sure.


Ok I’m now experiencing another problem. I can’t move, the game time is frozen, health/mana etc aren’t regenerating.

it’s because of GetTickCount

GetTickCount tends to “rollback”, meaning it goes to the max negative value of a Long. This essentially means that all values of tmr vars are still positive so when it checks to see if GetTickCount is higher, when in reality it’s below 0. i’ve posted a fix to this, somewhere on the forums for this

the flash timer might be for the weather, probably for like lightning and such.

I’m guessing the reason why it’s staying white is because GetTickCount isn’t changing. I’m sure I already added this fix i’ll have another look.

GetTickCount is changing, but remember, it’s in the negative values. TickCount basically just does a val = val + 1

Atm it would be in the negatives, so it’s still counting up but it’s going “down” if you can understand that(-999, -998, -997, etc.)

Yeah. Just added your fix. I remember adding the fix to my MUD game that uses Mirage Source and it fixed that also. It’s all working fine now, all issues solved. Thanks Growlith

no problem!

An alternative solution is to have anyone experiencing these problems to restart their computers. That will reset the tick count to 0 and then you won’t have a problem for another 20 something days.

I know this is an old topic but i’d just like to post something that would fix this even easier lol. instead of doing a host-based timer, you can do a hardcoded timer that your code handles instead of the system itself. simply just do a val = val + 1 every tick then check the value, after a certain value, reset the val and reset every other variable that used it previously. i haven’t tested how efficient this is however so you could expect some drop in performance. if any of you want me to test it out, i can do a quick mock up to show if there’s any drop in performance!

EDIT:
i’ve tested this and it does work, however there is a lot of things that would need to be changed in order to get everything to work properly.

-1

@jcsnider JC this is why I take people so literal in real life.
Part of me said " I shut my computer down though! That should be the same thing! I freaking reinstalled my runtimes! I even got the crappy Direct X and updated it! I am getting sick of this! aaaaaannnnnnnnddddddd… here we have smart ol’ JC saying just reset your computer… whatever… I’ll try literally just resetting my computer"

So now I want to know why shutting my computer down and leaving it for half an hour to an hour alone didn’t work but simply resetting did… Oh and JC if you’re still there at all reading this old topic… bite me… Robin was always better than you and I considered him my best friend! #insidejoke

@lel
Guys, please don’t be necro-ing threads to trash talk, thanks lol

Log in to reply