Runtime error 339 Component MSWINSCK.OCX missing or invalid

Every time I try to run the server or client for Eclipse Renewel or Andur Engine I get an error that says “Runtime error 339 Component MSWINSCK.OCX or one of its depenencies not correctly registered: a file is missing or invalid.”

I already looked for a solution and tried to follow the instructions from this thread and got the same problem as YankeeDooodle after doing the cmd prompt: “The module mswinsck.ocx failed to load. Make sure binary is stored at specified path or debug it to check for problems with binary or dependent .DLL files. The specified module could not be found”

The reply below that said “your issue most likely revolves around dll versioning, open the .vbp file in notepad, you’ll see 3 lines at the very top that will have the dependencies, find mswinsock, next, you’ll see 2.1.0, change it to 2.0.0”

What VBP file are they talking about and where is it? They didn’t say and it’s very unclear what they’re talking about. If anyone can help me work through this issue so I can get started I’d so greatly appreciate it ❤ thank you!! 🙂

I’ll ask the simple question to be sure: have you installed the runtimes? There is a link for them on the downloads page on step 2

https://www.eclipseorigins.com/downloads#step_two

Oh my gosh I didn’t even see that. Thank you SO much for your help 🙂 that solved it!

Log in to reply