How do I setup VB6 for use?

Hi, after installing VB6 I’ve tried to modify Andur engine’s source and I’m getting an error where it can’t find a user-defined type.

The part it gets the error at:
Private Sub lvwInfo_ColumnClick(ByVal ColumnHeader As MSComctlLib.ColumnHeader)
The error says exactly:
Compile error: User-defined type not defined. (It happens on any Engine I extract and try to modify.)
I didn’t do anything besides installing VB6 with the runtimes VB6Plus2.2 (which I took here on the forum) and
making VB6 compatible (for that ELO error) by changing the compatibility mode to Windows XP sp3.
I’ve downloaded Andur’s source, extracted, opened the .vbp and hit export to Server.exe. (Still give me an error.)

I’d like to know if there’s a way to either fix this or if there are specific things to install/configure to make it compile.

I really want to get back into making RPG’s on eclipse since it’s the only one that works kinda well since frog’s shut down…

Also, where can I find the accesses? I’ve searched every files I could and I can’t seem to find it ^^’…

Try installing this https://www.microsoft.com/en-us/download/details.aspx?id=5721

What do you mean “accesses”? Also, what engine are you using?
ER and Andur (in Andur’s next update) both have their admin ranks in modEnumerations. To give a player admin access, go to the server and right click their name in the player list.

If you’re using a different engine, then you should be able to find the admin ranks in modConstants.

@mohenjo-daro As of the accesses I meant the Ranks. On frog it was access levels (0-5). But yea, I wasn’t sure where to find it ^^ Thanks.

For the vb6 sp6, I’m downloading it right away and I’m trying it.
I’ll send a reply once done ^^.

Same error.
But I’ve got some object libraries not opening as well as I just noticed. (It wont say which one sadly.)

This post is deleted!

@SolidLink It won’t apply, it tells me object library not registered.

This post is deleted!

@solidlink It won’t work if I just try to ignore them I’ll try @Mohenjo-Daro link fix. Hopefully it works.

It worked, now I got an error with .ListItems which sends Compile error: Method or data member not found
The line is:
frmServer.lvwInfo.ListItems(index).SubItems(1) = vbNullString

This post is deleted!

@solidlink Well, I’m in the server.vbp already.
Otherwise is there a specific place to enter it besides Ctrl+t?

This post is deleted!

Can it be the .ListItems iteself that isn’t defined? It’s in the modDatabase.bas

Also, for info:
The only file that wasn’t registered was:
DBLIST32.OCX < Just for future reference if anybody needs.

Open the server.vbp with VB6, then press Ctrl + T and make sure the following boxes are checked

Microsoft Rich Textbox Control 6.0 (SP6)
Microsoft Tabbed Dialog Control 6.0 (SP6)
Microsoft Windows Common Controls 6.0 (SP6)
Microsoft Winsock Control 6.0 (SP4)

@mohenjo-daro The only winsock I have is SP6

This post is deleted!
This post is deleted!

@solidlink it’s already checked. Maybe if I try with another engine than Andur?

This post is deleted!
Log in to reply