Mohenjo Daro's Updater Tutorial: Setup Config

This tutorial will teach you how to setup the Config.xml file for your game/program.

I recommend using Notepad++ to open and edit all the Updater’s XML files.

alt text

The Config.xml file is located in \data\Config.xml.

alt text

Link to the below code: https://pastebin.com/Bn5sL7Gp

<config>
	<url>https://pastebin.com/d4sUURuC</url>
	<version>0.0.0</version>
	
	<executables>
		<name>Eclipse Renewal\client\Eclipse Renewal.exe</name>
		<name>Eclipse Renewal\server\Eclipse Renewal Server.exe</name>
	</executables>
	
	<closeAfterLaunch>True</closeAfterLaunch>
        <runAsAdmin>False</runAsAdmin>
	
	<language>English</language>
	<skin>Default\Default.xml</skin>
</config>

<url> This is the link to your version history
<version> This is the local version
<executables> This is contains <name> which are the executable names from the updater folder
<closeAfterLaunch> This is if the updater closes after launching the executables
<runAsAdmin> This is used to tell the updater whether to run the programs it launches with Admin Permission
<language> This is what language the updater will use
<skin> This is the current skin the updater will use



Setting up the config for your own game:

<url>
This should look something like this: <url>https://pastebin.com/d4sUURuC</url>
The link in the node is to the version history (it’s ER’s in this case).


<version>

Just set this to 0.0.0 so it will look like this: <version>0.0.0</version>


<executables>

This should include the path leading to the executable for the Updater to launch. The path should be from the folder the updater is in to the exe.
If the full path is
C:\Users\User Name\Desktop\Program Updater\Eclipse Renewal\client\Eclipse Renewal.exe
Then the <name> field will look like
<name>Eclipse Renewal\client\Eclipse Renewal.exe</name>


<closeAfterLaunch>

You will most likely want this to be true. It will close the Updater after the user launches the executables. So it will look like this: <closeAfterLaunch>True</closeAfterLaunch>


<runAsAdmin>

You normally won’t need this to be true, but if your program or game needs admin permission to function correctly, put this as True.


The rest of the nodes don’t need to be changed by you, the Updater will change them itself (that functionality will be added in one of the next updates).

Wow really easy to config, good job my Lord Mohenjo, i’ll try it right now.

Thanks :)) !!!

@ollixsykes I tried my best to make it as simple as possible 🙂 I’m glad I succeeded

@Giukko No problem, I wanted to help devs by making an updater they can use

Hey Mohenjo, anyway to force updater to open the game has a administrator after complete? because my game can only run in administrator, my anti cheat block, so i tested and cant open after update… i added manifest into my game.exe and everything ok, but the updater still does not recognize and open without administrator.

@ollixsykes Try running the updater in admin mode and see if that launches the game in admin mode. If that doesn’t work, I’ll see about adding an option for it in the config, but the updater will have to run in admin mode for that to work as well (as far as I know).

I tried, but it did not work, he start the .exe (on launch button) without asking permission.

@ollixsykes Right click the updater exe, click Properties, Compatibility, and select Run as Administrator. Then, try to run the updater and see if it launches the game as an administrator.

Also, I don’t know if there will be a prompt if the updater launches the game with admin permission when the updater is run with admin permission.

The updater launches in administrator, but the game does not, still no asking permission after click on launch button.

If there’s no way, no problem, i will remove Launch button, and add 2 shortcuts on desktop, game and updater in installer. But if you have any other ideas about it I’ll be happy to read.

@ollixsykes There’s a way, I was just curious if I had to add an option for it or if there was currently a way to do it. I’ll get to adding the admin permission tomorrow (the updater will auto update so you won’t have to redownload it)

Great, I’ll be waiting. Thank you!

@ollixsykes Alright, I added a new <runasAdmin> node to the config and the tut, it should be pretty clear. By default it’s blank or false.

I also changed a lot of the self updating code so there should be less bugs with it. You will have to do 1 of 2 things to get the updater to update properly…

  1. Redownload the updater and replace the new \data folder with the old one. (Once you run the updater, the <runAsAdmin> node will be added to the config).

Or

  1. Rename the updater exe to Program Updater.exe and the updater exe.config file to Program Updater.exe.config, run it and let it update, and rename it back to whatever you want (you won’t have to rename it again).

Sorry about this bug requiring more work than normal to update. This should be the last time you have to do anything other than start the updater to update the program.

Log in to reply